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Abstract

To describe the procedures for using Fluidigm “Real-Time PCR Analysis” software and “Olink NPX manager”

software to analyze Olink Assay data and generate final result reports. Fluidigm Real-Time PCR Analysis software

generates the Ct value of the PCR reaction and Olink NPX manager software calculates the Normalized relative

Protein Expression value (NPX) from the Ct value.

Materials

Computer

Fluidigm Real-Time PCR Analysis

Olink NPX manager

Troubleshooting

Safety warnings

Not Applicable
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Raw data Ct value analysis

1 Copy the Biomark File (entire Chip-run folder corresponding to the Olink assay) from the

Biomark Computer to USB drive, the size (~1.3 GB). There should be always 2 sub-

folders and 4 files in the Chip run folder.

2 Connect USB drive from above step with HIMC computer with installed Fluidigm Olink

PCR analysis software

3 Start the Fluidigm “Real-Time PCR analysis software (Version 4.5.2)”

4 Open the Chip run under “Quick Tasks”. This will redirect to a new window. Locate and

double click the Chip run file (.bml-format) in the copied folder in Step 1.

Notes: Only one Chip run-file can be open at a time. Before opening a new run-file, the

first chip run file must be closed.
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5 Import a sample set.    

5.1 Prepare a 96-well-plate sample layout for the Olink Assay in excel according to HIMC

format and save in HIMC shared drive or Google drive.

5.2 Double click Sample Setup in the Fluidigm Olink PCR analysis software. Select container

type (SBS plate) and container format (e.g. SBS96) in the Sample Plate Set-up Wizard,

press OK.

5.3 Copy the Olink assay sample layout from the plate layout excel file saved in Step 5.1, right

click well A1 in the Sample Set-up “Editor” panel.

5.4 Select “Sample Name” under Data Item Selection.

5.5 Write Run name in the “Name” section under plate settings. Select mapping will open a

new window. Different mapping files will be seen in that window.

5.6 Select “M96-Sample-SB96.dsp” for the Mapping.
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6 Import a Detector setup:

6.1 Select Detector Setup and Click the New button.

6.2 Click on the import button. Choose the .plt-file corresponding to the Olink panel kit used

for the assay (i.e. for Inflammation panel use “Mapped Inflammation I 96x96 Detector

Setup.plt”).

Notes: Check the Olink kit contents Paper insert for Lot # and the proper .plt file

information. New version of .plt file may need to be downloaded before analysis based

on kit lot#. All the assay .plt files from Olink are downloaded from Olink website and

saved on:

J:\gtherapy\HumanImmuneMonitoringCenter\Olink_proteomic2016\NPX_analysisSoftwar

e\mt Sinai

6.3 In the case of a project with different lot # kits, one will need to have the same reference

samples in plates with biological samples for normalization purposes. However, if the

“Data File No: XXXX” which comes in the paper with the kit is the same, then the data

from the different kit lot numbers can be analyzed as a project.
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7 Analysis settings:

7.1 Select Analysis Views/ Details Views.

7.2 Set Quality Threshold to “0.5”, Baseline Correction to “Linear” and Ct Threshold Method

to “Auto (Global)”, (by changing the default settings) and Click Analyze button. These

settings are common for all the Olink panels.
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8 Data preview:

8.1 Select “Results Table and drop down. Select Heat Map View.

8.2 Review the Heat Map. The Negative Ctrl samples should give a darker “line” from left to

right and IPC samples should give a brighter “line” from left to right (Bright color

corresponds to more fluorescence, i.e. a lower Ct value and therefore a higher protein

concentration). Check if any line of samples/assays has a Black square point that means

the assay failed in that Chip well.

8.3 Check the Image view by changing to Image View instead of Heat Map View. Choose

FAM-MGB and cycle no. 4 in the drop-down menus. Then Click the button Toggle

Overlays (square) to remove the red grid pattern. Dual views can be used to figure out

which samples that show pixels or line in chip. These samples should be removed from

further analysis.
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8.4
Check the Heat Map View by selecting the Heat map view tab on the top of detail view. If

there is any analyte or sample has dark purple line with black crossed out square, then

remove the data of this analyte/sample in the Olink NPX manager for further analysis.

Follow the Step 28 to remove the data from NPX manager.
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Note: The following figures are examples of different Ctrls/sample/analyte conditions and

can be used for reference view only, while analyzing other plate data. These examples

are taken from Olga_IO_10162017.

8.5 Select Incubation Ctrl-1 in the Detector on heat map and it will appear as the following

figure with the amplification curves.
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8.6 Select Incubation Ctrl-2 in the Detector on heat map and it will appear as the following

figure with the amplification curves.

8.7 Select Extension Ctrl in the Detector on heat map and it will appear as the following

figure with the amplification curves.
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8.8 Select Detection Ctrl in the Detector on heat map and it will appear as the following

figure with the amplification curves.
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8.9 Select an assay with bright yellow color in whole column in the Detector on heat map and

it will appear as the following figure with the amplification curves. This is the highly

expressed/more concentration of protein.

8.10 Select an assay with Dark purple color in whole column in the Detector on heat map and

it will appear as the following figure with the amplification curves. This is the lowest

expressed/low concentration of protein.
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8.11 Select NC (Negative Ctrl) in Samples on heat map and it will appear as the following

figure with the amplification curves. This should always be purple (dark line) color

because it is negative Ctrl.
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8.12 Select IPC (Positive Ctrl) in Samples on heat map and it will appear as the following

figure with the amplification curves.This should always be yellow (bright line) color as it

is positive ctrl.

The X marked wells/squares shown in below heat map picture in Analyte IL-4 indicates

there is no Data.

Data Export
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9 Select File>Export. Make sure to choose Heat Map Results (*csv) for File format from

“Save as Type” drop down. Name the excel file according to HIMC format

“HIMC_PI_Date_Ct.csv”

10 Open the exported CSV file in excel software to ensure of the header, Olink ID, sample

names and Fluidigm QC result.

Transform Ct values to NPX using “Olink NPX manager”

11 Open NPX manager software version 2.1.0.224 on the same computer.

12 Default mode/setting for the Project Options are shown below:
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13 Import Ct Value/.csv file data: Select “File” > “Import CSV” to import the xxxx.csv file.

e.g. “HIMC_PI_Date_Ct.csv”

13.1 During import, Olink NPX Manager Software will check for duplicate sample names. If

duplicate sample names are found, a message will be shown with the names of the

duplicate samples. Press OK. 

Note: Multiple files within the same project can be selected for import at the same time.

13.2 Next screen is for the “Select Panel Version”
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13.3 Each imported run is automatically annotated with the correct Olink Panel. Click OK

14 Enter project information:

14.1 Go to the “Project”. Project Name will be displayed in the data export file and the

Certificate of Analysis (CoA). Information about Sample type, customer, business

development manager and analysis lab will be displayed in the CoA. Comments will be

saved in the Olink NPX Manager Project (oaf) file. Comments for report and Flagged

Positions will be displayed in the Certificate of Analysis (CoA).

14.2 Fill out required Project information.
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15 Go to “Plate View” Verify sample and data annotation.

15.1 Verify the plate layout. The layout can be changed by right-clicking on a selected well, or

a selection of wells, and changing the well type to any of the available selections:

Sample, Control, Negative Control, IPC and Not Used.

15.2 Select all 3 NC wells (NC, NC-2, NC-3) and mark them as Negative Control. Repeat Steps

15.1 and 15.2 for all imported plates.

16 Calculate NPX

16.1 Highlight an Olink Panel in the left pane tree node. Click on “menu Analysis” > “Calculate

NPX”. Randomized studies with more than one sample plate will be intensity normalized

if we select the “Samples Randomized” check box under the project tab before

normalization or by clicking on Analysis” > Intensity Normalize v.2. Other study set ups

will be IPC normalized by default. The “Intensity Normalization” will calculate the median

of all the plates and individual plate NPX values will be normalized based on the median

value of the all plates.

16.2 Default view is Ct Value. To view NPX values, select NPX Value in the status bar in the

top left corner of the main window and go to Data view tap.
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17 Quality control data (per sample plate)

17.1 Select a plate in the left pane tree node and go to QC View

17.2 Check acceptance criteria Run QC:

Number of flagged samples less than 1/6th of the total number of samples (16

samples in a full plate)

Standard deviation < 0.2 NPX for each of Incubation control 1, Incubation control 2

and Detection control

17.3 Acceptance criteria Sample QC

Incubation Control 2 deviations from median of plate: < +/- 0.3 NPX

Detection Control deviation from median of plate: < +/- 0.3 

NPX Samples that deviate more than +/- 0.3 NPX will be marked as flagged

18 Evaluate results in selection information (based on NPX values)

18.1 Plate ANOVA (if more than one sample plate per panel) < 10

18.2 Row/Column ANOVA: < 30 OK, 40-60 Investigate further
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18.3 If more than 5 LODs highlighted yellow under LoD view tab, deviating from the values

observed (+/- 2.5 NPX: which is Olink recommended value), check the following steps:

If One of the negative Control samples is flagged in the NPX software, this control has

to been marked “not used sample” before calculating the NPX

Check the Heat map view to show only negative controls to see if any one negative

ctrl is different from other two that it has many dark “BLUE” values (= low Ct = high

NPX which affects the LOD value) by going through the “assays”.

In such a case remove that negative ctrl by marking it “Not Used” and reanalyze the

NPX data.

19 Export data

19.1 Select NPX Value in the status bar in the topleft corner of the main window

19.2 Under Project Options in the Project tab, select whether NPX values below LOD should

be exported as NaN or replaced with the value for LOD or Actual Value (below LOD).

Select menu File > Export Data.

19.3 Click “Yes” if exporting data for all plates together and “No” for exporting data on

selected plate only. Select desired export settings.
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19.4 Enter filename and export format (Excel files *.xlsx or CSV-files*.csv) in the Save-dialog

and click the Save button.

20 Export certificate of analysis: Select menu File > Report > Save Certificate of Analysis.

Analysis for Multi-plates Project Per Olink Panel

21 For randomized projects with more than one plate per Olink panel, follow Steps 11

through 15.2 for all plates one after another.

22 Imported plates are grouped by Olink panel and displayed in the left pane tree view.

Plates can be reorganized in the tree view by drag-and-drop.

23 Then check the Samples Randomized box under Project Options to analyze data using

Intensity Normalization. Intensity Normalization can also be applied by Clicking intensity

Normalize v.2 under Analysis tab. Follow the Steps from 16 and further analysis.

24 Click the + sign next to an Olink Panel name to expand the tree node and reveal all

imported runs for the Olink panel. Highlight the first run and go to the Plate View tab
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Verify the data file version

25 For using the NPX software do the multi-plate analysis, check the plate Z-score for each

anlayte. If one/more sample spots are far from the 0- line, then check the Ct value, NPX

value and also check the Chip image in RT-PCR analysis software if there is any Chip line

has issues- meaning dark line mentioned in Step 8.3. The sample/s should be removed

from analysis.

Troubleshooting

26 EXAMPLE OF data set without any flagged samples by NPX manager but needed to be

corrected manually

When 1 or more samples have Ct value VERY different (darker red or darker blue

color) from the rest of the wells on the plate but that sample is not flagged by NPX

manager

The sample is not flagged because the NPX-values for Incubation control 2 and

Detection control were within accepted limits.

All four controls are affected for that sample and when using the extension control to

get the NPX value, the NPX values for Incubation control 2 and Detection control

happen to be within accepted limits.

When the extension control is affected in the same way as the other controls,

meaning that all four controls have lower or higher Ct values than the rest of the plate,

this difference can disappear in the normalization step.

In this case, the sample should be marked as “failed” in the plate view tab and the

data for that sample will disappear and will show “No Data” in data view tab. For

example in DEP Culture samples inflammation Olink panel, see below:
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26.1 If sample/s is flagged in a row/column and all internal controls and analytes have

high/low Ct values compared to that of the whole plate, it could be an error while adding

detection mixture in those wells.

26.2 If same samples of the study or healthy donor plasma/serum samples were on all plates

they will be used as control for analysis, Olink uses Plasma pool of 20 HD samples. The

intra assay %CV for control sample is recommended <10% and that of inter assay is

<15%.

NPX manager uses highest LoD value out of all plates LoD values.

27 Check if the chosen (highest) LoD affects more than 50% of the samples for that

analyte/protein detected in all the plates meaning this high LoD value is used for more

than 50% samples on all plate.

28 In this case, mark that assay failed for that Highest LoD value analyte on that one

specific plate.

1. by selecting that plate on theleft pane tree view, go to Data View

2. Select analyte by RIGHT click on the analyte and mark as failed.

3. A comment box will appear where associated comment can be made and all values

for that analyte will be shown as “No Data”.

4. Now select Olink panel (all plates) on left pane tree view to recalculate.

5. Confirm % of protein detected for the analyte in question with LOD.
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HOWEVER: optionally,

Note: When we have too very different LODs between the two plates for some analyses

and, therefore, lose the data points of one plate (with low LOD) due to the other plate,

which has the higher LODs for that specific analytes, one can remove the “NEGATIVE

CONTROL”. AT THE Data View- Display only “Neg Ctrl”, right-click the NC, NC2, NC3 for

the specific analyte (depends on the variation- remove all or the only one w HIGH LOD)

and select the “ Mark as Failed”. This will remove the high- LOD for that analyte.
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Protocol references

REFERENCE- Fluidigm Real-Time PCR Analysis and Olink NPX manager user Guide

http://www.olink.com/products/document-download-center/)
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