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License: This is an open access protocol distributed under the terms of the Creative Commons Attribution License, which

permits unrestricted use, distribution, and reproduction in any medium, provided the original author and source are credited

Protocol status: Working
We use this protocol and it's working

Created: October 02, 2019
Last Modified: October 10, 2019
Protocol Integer ID: 28296

Keywords: Image J, quantification, gel, western blot, quantification of gel band, peak quantification tool, easy quantification of
band, fluorescent gel, gel band, peak quantification tool this protocol, median intensity around roi boundary, median intensity,
qguantification algorithm, image studio lite software, dot blot, routine quantification task, bands with rectangle, background level,
selecting band, image, roi boundary

Abstract

This protocol offers an Image J macro/plugin that enable easy quantification of bands on western blots, dot blots,
and fluorescent gels etc., by simply selecting bands with rectangle or oval tools as region of interest (ROI), and
running this macro. This macro automatically estimates background level based on mean or median intensity
around ROI boundary, and should help you speed up your routine quantification tasks. Note that the quantification
algorithm is similar to that used in Image Studio Lite software (freely available from LI-COR Biosciences), which is
widely used for quantification purpose in many publications.
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Guidelines

This macro allows you to quantify bands or peaks from gel/blot images, by simply selecting bands with rectangle
or oval tools as region of interest(ROI),and starting this BandPeakQuantification macro. The algorithm is basically
the same as that implimented in a free, commercial software Image Studio Lite(LI-COR Biosciences), which has
been widely used in many publications.

The trick is that background signal is estimated from a slightly-expanded ROI, and the calculated background is
subtracted from the total integrated signal within the ROI(seefigures below). By default, the background is
calculated from simple expansion of the ROI, users can also select top/bottom or sides options to further define
how background intensity is estimated. Also, users can select mean or median for the calculation of the
background intensity from the expanded ROI.

This macro is compatible with rectangle, circles including ovals, and free-hand selections(notethat top/bottom or
sides options are only applicable to rectangles). By using ROl Manager tool in the Image J/Fiji, all the ROIs can be
quantified in one go.
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Expected result

Example dot blot image
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Expected result

Quantification of western blot bands

1. Open TIFF image
(in this case 8-bit TIFF) 28 OJojx|v]~|4

s
P
— - ..
x=696, y=84, value=246

-
-
-

Note: -~

Image intensity at the
cursole position can
be read from the
ImagedJ main window

2. Edit > Invert
(if necessary)

Note:

Size of the ROIs
needs not to be the
same with this macro.

3. Start ROl Manager
(Analysis > Tools)

4. Register ROIs
(select then Cmd+t)

5. Start the "Band/Peak Quantification" macro ece BandRaak Quagtificationfoo)

Note:
In this case, "top/bottom" option for the
background estimation method is more suitable. = Estimate background from (rectangle selection only): | top/bottom a

-

- Background estimation by: median s

background width (pixels) 3

"top/bottom" L

]

| ]

I - I

I ROI for : Reset scale:
| background estimation ,

2 | Cancel OK

Example image from: Degasperi A, Birtwistle MR, Volinsky N, Rauch J, Kolch W, Kholodenko BN (2014) Evaluating Strategies to
Normalise Biological Replicates of Western Blot Data. PLoS ONE 9(1): e87293.

Quantification by lane-profile method
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Before start

This protocol requires a cross-platform image analysis software, ImagedJ or Fiji.

Software
Imaged NAME
Software
Fiii NAME
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Installation of ImagedJ and the macro

1 Down load the following ImagedJ macro file (_BandPeakQuantification.ijm) and place in a
directory under the Imaged plugins directory.

ﬁ _BandPeakQuantification.ijm

Note

“« n

For example, save the ijm file in“Applications> ImageJ > plugins”. With the“_"character at
the start of the filename, ImageJ automatically recognize this macro file at startup, so that
you can see the macro listed in the “Plugins” menu. Alternatively, you can do "Help >
Update Menu" to make the newly installed macro in the menu.

Note

Within ImageJ's plugin directory, you can use subdirectory (or folder) to store multiple
macros in an organized manner.

Quantification of dot blot with this macro

2 Open your image. Here, in this example, we use a sample dot blot image provided with m
ImagedJ software. Open the image from "File > Open Samples > Dot blot".
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Expected result

An example image (dot blot) from ImageJ sample images.

3 If needed, invert the image ("Edit > Invert").

Note

By placing the cursole on the image, you can see intensity value on the Image J main
window. Background should be low intensity and signals should show high intensity.
Basically, Imaged shows background as black and high-intensity region as white.
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Expected result

4 Start ROl Manager, which you can find at "Analyze > Tools > ROl Manager", and check
“"Show all" and “Labels" options.
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Expected result

[ ] [ ] ROI Manager
Add [t]

Update
Delete
Rename...
Measure
Deselect
Properties...
Flatten [F]
More »
Show All
Labels

5 Place a rectangle (or circle) on the band, and register the ROI (regionof interest) to the
ROI Manager by “Command + t" (forMac) or “Ctrl + t" (for Windows) or click "Add" on
the ROl Manager window. Note that you can display the ROIs with numbering by
checking .

Note

Note that you can change image contrast ("Image > Adjust > Brightness/Contrast" or
"Process > Enhance Contrast") to make it easier to select ROls. However, do not click
"Apply" in the Brightness/contrast window, or do not check "normalize" in the Enhance
Contrast window, as these operations alter image itself.
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Note

Note that this macro can quantify single selection of a band without using ROl Manager.
Simply select your band, and run the macro, and you can get the quantification result in
the Results window.

6 Select next band, and register the ROl again. Repeat for all the band you want to
quantify.

Note

With this macro, the size of the ROIs needs not to be the same, as this macro quantify
integrated intensity above the background. So you can define appropriate ROI of different
size for each band.

Expected result

® O @® ROIManager
513x282 pixels; 8-bit (inverting LUT); 141K
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0101-0404 Flatten [F]
.= . ||looss-0468
2 - More »
{ . |lo185-0043
® 0 ® @ @ oo
. 0179-0186 Show Al
0178-0258 Labels

N175_N230

7 Run the “BandPeakQuantification"macro from Plugins > BandPeakQuantification on the
menu bar. Within the Band/Peak Quantification Tool window, you can set several options,
as described in the following notes.
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Note

"Background with (pixels)" means how much you expand the ROI for background
estimation (see also Guidelines section).

Note

You can select all, top/bottom, or sides for the "Estimate background from" option. If set
to "all", background ROl is made by expanding the ROI by background width pixels. If set to
"top/bottom", background is estimated only top side and bottom side of the ROI (only
applicable for rectangle ROIs). If set to "sides", background ROl is placed on both sides of
the ROI.

Note

You can select "median” or "mean" for how background is estimated from the region
around the ROI. "Median" (default) can be more robust, as it is less sensitive to outliers.

Note

The reset scale option is checked by default. This option is required only when the image
scale (um/pixel) is set. Note that by running this macro, the scale will be reset.
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Expected result

® & Etland,-fpeak Quantification Tool
background width (pixels) 3
Estimate background from (rectangle selection only): all ﬁ
Background estimation by:  median ﬁ

Reset scale

Cancel oK

8 All the ROIs listed in the ROI Manager will be quantified. You can save the results as a
CSV file from right click on the result window, or copy & paste to Excel or other
softwares.

Expected result

e0e Results
[signal [total Jarea [mean  [mean_background [ROI_x [ROLy [ROILw [ROI_h |

1 30621.000 119437 1456 B82.031 61 16 19 42 44
2 6365.000 89357 1456 61.372 57 88 16 42 44
3 4496.000 84576 1456 58.088 55 162 16 42 44
4 17689.000 96313.000 1456 66.149 54 229 13 42 44
5 23150.000 97406.000 1456 66.900 51 304 10 42 44
6  24220.000 95564.000 1456 65.635 49 375 7 42 44
7 3125.000 68645.000 1456 47.146 45 447 8 42 44
8 8366.000 94270.000 1456 64.746 59 19 92 42 44
9 37775.000 126591.000 1456 86.944 6l 92 87 42 44
mn A7NQeC Nnn. 1272080 NnNN. 1ATK @1 220 ©a 16872 Q7 A AA
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Note

Note that "signal” column denotes the background corrected integrated intensity. The
“total" column is the integrated intensity within the ROl without background correction.

Quantification of a dot blot with traditional lane-profile method

9

10

11

12

13

Make ROI for the first lane of the gel in this case, | used horizontal rectangle). Press Cmd
+ 1 (or Ctrl +1 or Analyze > Gels > Select First Lane).

Select next lane and press Cmd + 2 (or Ctrl + 2 or Analyze > Gels > Select Next Lane).
Repeat for the other lanes.

Press Cmd + 3 (or Ctrl + 3 or Analyze > Gels > Plot Lanes) to plot lane profiles.

Draw lines at the bottom of the peaks, so that uneven background is accounted for.

Note
A limitation of this method is that baseline can not be drawn for small peaks, as the lane

profile tool does not offer zooming function.

From Image J tool bar, select Wand tool. Click the peaks and the calculated peak area is
displayed in the Results window.

Note

Note that this wand tool quantify area surrounded by lines (closed area). So you need to
make the peak area closed by lines.

Another example: western blot

14

Open the image.
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Note

The example data was extracted from a published article(DegasperiA, Birtwistle MR,
Volinsky N, Rauch J, Kolch W, Kholodenko BN(2014)Evaluating Strategies to Normalise
Biological Replicates of Western Blot Data. PLoS ONE 9(1): €87293.). The data was from
western blot of serially diluted BSA(2-folddilution) detected with an enhanced
chemiluminescence reagent and a CCD camera system.

Expected result

15 Select ROIs and add to the ROl Manager as described above.

Expected result

16 Run the Band/Peak Quantification Tool macro, and set the "estimate background from"
option to "top/bottom".
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Expected result

[ ] ] Band/Peak Quantification Tool

background width (pixels) 3

Estimate background from (rectangle selection only): top/bottom ﬁ

Background estimation by: = median a

Reset scale:

Cancel OK

Note

In this case, it would be more reasonable to estimate top and bottom sides of the ROI.
Also, the sizes of ROIls can be different, depending on the intensity of the band (generally,
high-intensity band requires larger ROI).

17 The quantification results will be shown in the Results window. Save as CSV file or copy
to Excel for further analysis.
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Expected result

[ JoX | Results
[signal [total larea [mean [median_background [ROILx [ROLy [ROLw [ROLh |
1 1052093 1216829 20592 59.092 8 1106 26 104 198
2 937885.000 1080645 14276 75.697 10 1016 40 86 166
3 738535.000 838983 12556 66.819 B 924 52 86 146
4 392521.000 462353 9976 46.347 7 838 64 86 116
5 315443.000 375299 9976 37.620 b 744 64 86 116
6 185239.000 245095 9976 24.568 6 654 64 86 116
7 86028.000 145884 9976 14623 6 560 64 86 116
8 45240.000 105096.000 9976 10.535 6 468 64 86 116
9 20907.000 B80763.000 9976 8.096 6 376 64 86 116
10 2590.000 62446.000 9976 6.260 6 282 64 86 116
11 9527.000 69383.000 9976 6.955 6 194 62 86 116
12 2197.000 62053.000 9976 6.220 6 100 62 86 116
Expected result
Comparison of the "Band/Peak Quantification" macro and the lane-profile method
. ° ? ° o I [
800 - g 0
‘5 [=]
o g o 5
8 600 g 3 g 30
e & 2
3 =y o
% 400 o 82 ° 8
7] o ® o ]
° o
2001 o & 10 s 10
= w
S g g &
0 8 0 8 0
000 025 050 075 1.00 0.00 025 0.50 1.00 0 200 400

Relative amount of BSA

Relative amount of BSA

Signal/1000 (this macro)

Both of this macro and the traditional lane-profile method gives similar quantification
results, with high correlation. Note that the western blot intensity is not always linear
against the amount of the protein in the input. For quantitative comparison, it is

important to use linear range.
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