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License: This is an open access protocol distributed under the terms of the Creative Commons Attribution License, which

permits unrestricted use, distribution, and reproduction in any medium, provided the original author and source are credited

Protocol status: Working
We use this protocol and it's working
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Abstract

The enteric nervous system is an important regulator of gastrointestinal, digestive and metabolic function. Here
we describe protocols for clearing rat gastric tissue with the Clearing-enhanced 3D microscopy (Ce3D) method to
increase optical clarity, to allow the use of thick tissue preparations for quantitation of the number and size of
myenteric and submucosal ganglia in the rat fundus, corpus and antrum
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Materials

Ketamine, Vendor, Cat#

Xylazine, Vendor, Cat#

Heparin, Sigma-Aldrich, Cat#

Dimethyl Sulfoxide (DMSO), Vendor, Cat#

Triton X-100, Vendor, Cat#

Bovine Serum Albumin (BSA), Vendor, Cat#

1-thioglycerol, Vendor, Cat#

Histodenz catalog #D2158 Sigma, North Ryde, NSW, Australia
N-Methylacetamide catalog #M26305 Sigma, North Ryde, NSW, Australia

Primary antibody:
Human anti-Hu C/D antibody Gift from Dr Vanda Lennon, Mayo Clinic, Rochester, Minnesota, USA
RRID:AB_2314657

Secondary antibody:
Donkey anti-Human Alexa Fluor 594 RRID:AB_2340572, Jackson ImmunoResearch Labs Catalog #709-585-149

Microscope
ZEISS LSM 800, Zeiss, Sydney, Australia

Software:

Zeiss Zen Blue
ImagedJ

3D ImagedJ suite
MorphoLibJ plugins

Troubleshooting
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Safety warnings

O Al steps involving the following chemicals should be carried out inside a chemical fumehood, and collect

all waste into a labelled waste container

N-Methylacetamide

Reproductive toxicity.

May damage fertility or the unborn child.

‘Wear protective gown and gloves

-Recommend nitrile gloves

‘Use only in a chemical fumehood.

-Avoid breathing dust/ vapours/ aerosols

-If swallowed, seek medical attention without delay, refer to MSDS.

-This material and its container must be disposed of as hazardous waste.

-Do not dispose down drain even if dilute, collect into labelled waste container.

-Collect any spillage for appropriate disposal.
-Dispose of diluted solutions in labelled CE3D WASTE container.
-Keep containers tightly sealed

1-Thioglycerol

May cause respiratory irritation.

Harmful if swallowed.

Harmful in contact with skin.

Causes skin irritation.

Causes serious eye irritation.

Suspected of causing genetic defects.

May cause an allergic skin reaction.

‘Wear protective gown and gloves

-Recommend nitrile gloves

‘Use only in a chemical fumehood.

-Avoid breathing dust/ vapours/ aerosols

-Keep containers tightly sealed

‘If swallowed, seek medical attention without delay, refer to MSDS.

-This material and its container must be disposed of as hazardous waste.
Do not dispose down drain even if dilute, collect into labelled waste container.
-Collect any spillage for appropriate disposal.

-Dispose of diluted solutions in labelled CE3D WASTE container.

Formaldehyde (40% solution):
Fatal if inhaled.

Toxic if swallowed.

Toxic in contact with skin.
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Causes severe skin burns and eye damage.

May damage the unborn child.

May cause cancer by inhalation.

May cause damage to organs.

May cause an allergic skin reaction.

Combustible liquid.

Harmful to aquatic life.

‘Wear protective gown and gloves

-Gloves must be removed/changed immediately upon spillage/contact.
‘Use only in a chemical fumehood.

-Do not breathe fumes/ vapour.

-If swallowed, seek medical attention without delay, refer to MSDS.

-This material and its container must be disposed of as hazardous waste.
-Do not dispose down drain even if dilute, collect into labelled waste container.
-Collect any spillage for appropriate disposal.

-Dispose of diluted solutions in labelled FIXATIVE WASTE container.
-‘Keep containers tightly sealed.

‘Keep away from sources of ignition.

Picric acid:

(supersaturated solution, containing not less than 30% water: for safety)
Toxic if inhaled

Toxic in contact with skin.

Toxic if swallowed

Flammable

Harmful to aquatic life

Dry picric acid: Risk of explosion by shock, friction, fire or other sources of ignition.
‘Wear protective gown and gloves

-Gloves must be removed/changed immediately upon spillage/contact.

-Use only in a chemical fumehood.

Do not breathe fumes/ vapour.

‘If swallowed, seek medical attention without delay, refer to MSDS.

-This material and its container must be disposed of as hazardous waste.

Do not dispose down drain even if dilute, collect into labelled waste container.
-Collect any spillage for appropriate disposal.

-Dispose of diluted solutions in labelled FIXATIVE WASTE container.

-Keep containers tightly sealed. Keep away from sources of ignition.

-Keep wetted with water. Do not allow material to become dry. (see above)
‘Wipe up spills immediately.
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1 Experiments were conducted on male and female Sprague-Dawley rats of 6.5-8 weeks
(175-220 g female, 220-360 g male). Procedures were approved by the University of
Melbourne Animal Ethics Committee. Rats were supplied with food and water ad libitum
prior to the experiments.

2 Rats were deeply anaesthetised with a mixture of ketamine (55 mg/kg) and xylazine (9
mg/kg) prior to being perfused transcardially with heparinised phosphate buffered saline
(PBS: 0.15M NaCl, 0.01M sodium phosphate buffer, pH 7.2) followed by fixative (2%
formaldehyde, 0.2% picric acid in 0.IM sodium phosphate buffer, pH 7.0). The stomach
was removed, dissected, and post-fixed overnight at 4°C in the same fixative, before
being cleared with 3 x 10 min washes in dimethyl sulfoxide, 3 x 10 min washes in PBS
and then stored in PBS-azide (0.1% sodium azide in PBS) at 4°C.

3 Make solutions:

40% (vol/vol) N-methylacetamide stock

CAUTION: N-methylacetamide is a presumed human reproductive and fetal toxicant.
Use a chemical fume hood at all times and collect waste in designated Ce3D waste
container.

N-methylacetamide is solid at RT.

Place the entire bottle of 100% N-methylacetamide into a 37°C incubator for >1 hr, until
fully melted.

Pre-warm a 25ml pipette to prevent N-methylacetamide sticking to the pipette wall.

= Transfer 20ml of 100% N-methylacetamide to a 50ml conical tube.

= Add 30ml of PBS (RT) to the 20ml of liquid 100% N-methylacetamide

= Mix to make a 40% (vol/vol) stock solution.

Store tightly capped at RT for up to 2 months.

Note - prepare multiple 20ml aliquots to avoid having to melt the whole jar each time.
Close tightly and store 20ml aliquots of solid 100% (v/v) N-methylacetamide at room
temp.

Ce3D clearing solution
[22% (w/v) N-methylacetamide, 86% (w/v) Histodenz, 0.1% (v/v) Triton X-100, 0.5%
(v/v) 1- thioglycerol]

CAUTION: N-methylacetamide is a presumed human reproductive and fetal toxicant.

Use a chemical fume hood at all times and collect waste in designated Ce3D waste
container.
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It takes 2hr to make the Ce3D clearing solution; it is usually prepared during the tissue
staining/washing steps.

Calculate how much you will need, and scale up accordingly
Per 4.6ml:

= Add these reagents to a 10ml tube in the order given

= 2ml of 40% (v/v) N-methylacetamide

= 49 of Histodenz

= an additional 750ul of 40% (v/v) N-methylacetamide

m 5ul of Triton X-100.

CRITICAL Histodenz is layered between two layers of the 40% (v/v) N-methylacetamide
to promote faster dissolution.

= Seal the tube with Parafilm.

= Place the tube, upright in a rack, in the 37°C shaking incubator

= set to 150rpm for 15min then increase to 225rpm for Thr

= |ay tube horizontally in shaker (secure with masking tape) to assist mixing, incubate
for a further 1hr hour at 37°C, 225rpm

CRITICAL Ce3D clearing solution will go from an agglomerated whitish liquid to a fully
mixed clear liquid.

Ensure complete mixing of the Ce3D clearing solution, as incomplete mixing will change
the Ce3D

clearing properties.

= Add 25ul of 1-Thioglycerol to the mixed Ce3D clearing solution. This reagent helps to
reduce tissue discoloration during clearing

= Mix for 5min at slow speed on the rotary mixer at RT

= Expected refractive index (RI) = 1.495-1.505.

Stored at RT for up to 4 weeks in a falcon tube sealed with Parafilm.

Before using, heat to 37°C and use a transfer pipette or another mixing tool to ensure
that the Ce3D clearing solution is fully mixed

4 Clearing and staining:
Methods are adapted from

e Bossolani, G.D.P. et al., Neurogastroenterol. & Motil. 31, 13560 (2019)
e Li, W. et al., Nature Protocols. 14,1708-1733 (2019)
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e Cut full thickness pieces (~0.5x0.5cm) of rat gastric tissue from the fundus, corpus
and antrum.

- Recommend carrying out incubations in a suitably sized tissue culture plate so that
tissue can remain flat while being fully immersed in a small volume of solution.

- Plates should be placed in a humid box to prevent evaporation.

e Place tissue in blocking buffer (PBS-azide with 0.3% (v/v) Triton X-100, 1% (v/v)
BSA, and 1% (v/v) normal horse serum) to block for 24hr at 37°C
- Use enough solution to easily cover the tissue

e Place tissue in primary antibody (human anti-Hu 1:4000 in PBS-azide with 0.3% (v/v)
Triton X-100, 1% (v/v) BSA, and 1% (v/v) normal horse serum)

- Use enough solution to cover the tissue

- Incubate in a humid box for 4 days at 37°C then 1 day at room temperature (RT).

« From this point on - work inside a chemical fumehood for all steps, collect all waste
into labelled Ce3D waste container.

e Wash tissues with Ce3D washing buffer (PBS-azide with 0.3% (v/v) Triton X-100 and
0.5% (v/v) 1-thioglycerol)
Use an excess volume of wash buffer for all washes

- 3 x 30min washes at RT followed by 1 wash overnight at RT

e Place tissue in secondary antibody (donkey anti-human 594 1:250 in PBS-azide with
0.3% (v/v) Triton X-100).

- Use enough solution to cover the tissue

- From this point on, protect from light during all incubations.

- Incubate in a humid box for 2 days at 37°C

e Wash tissues with Ce3D washing buffer

- 3 x 30min washes at RT

- Replace with fresh Ce3D washing buffer and incubate the plates at RT for a further
2 days, changing the buffer every 24hr.

e Prepare Ce3D clearing solution (22% (w/v) N-methylacetamide, 86% (w/v)
Histodenz, 0.1% (v/v) Triton X-100, 0.5% (v/v) 1- thioglycerol) while tissue is washing

e Gently dab the samples on a Kimwipe to eliminate excess washing buffer and place
the samples directly into the Ce3D clearing solution

- Use enough solution to easily cover the tissue

- Note which side of the tissue is facing up (muscle or mucosa) as this is harder to
identify after clearing.
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- Incubate at RT for 3 days, change into fresh Ce3D clearing solution every 24hr

e Mount the samples onto slides with fresh Ce3D clearing solution

- Due to the thickness of the tissue and the fact that the mounting media does not
set, you will need a spacer to form a frame around the tissue between the slide and the
cover slip.

- Recommend 3D printing a frame - the outer edge approximately the size of your
coverslip, 1-2mm thick depending on your tissue. Ensure top and bottom surfaces are
smooth before mounting.

Superglue the spacer to the slide

- Fill the inside of the frame with fresh Ce3D clearing solution

- Place tissue into the Ce3D clearing solution, ensure muscle side of the tissue is
facing up, and that tissue is flat

- Place small drops of superglue on the spacer and carefully apply the top coverslip,
avoid bubbles

- Seal the edges and hold in place with multiple coats of nail polish.

 The mounted samples can be stored in the dark at RT for up to 1 week.

5 imaging:

Samples were imaged as z-stack tile scans with a nominal optical thickness of 7.7 um
using a 10x objective on the LSM800 confocal microscope (Zeiss, Sydney, Australia).
The upper and lower limits of the z stack were chosen to include all Hu positive staining
(myenteric and submucosal neurons) for the entire tile region.

Save as czi files (sourcedata).

6 Preparing image for Macro
Open czi image in Zen software (Zeiss, Sydney, Australia)
e Zen > Processing > Split scenes - to separate multiple scans into individual files if
needed

- Rename: sam-xxx_ses-hu-594.czi where sam-xxx refers to sample name

e Zen > Processing > Stitching - to correct for tile edge overlap and fuse tiles.
- save the stitched output file.

Open the stitched output file in ImagedJ (http://imagej.nih.gov/ij/).

+ Imaged > Process > subtract background
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- (settings: radius 10 pixels, all boxes unchecked)
- Save as tif > sam-xxx_ses-hu594_bg10.tif

Close files

Ensure each prepared tif image is saved in a separate folder, FOLDER-A, ready to run the
macro.

7 Quantitation of rat gastric enteric ganglia

Quantification was completed in Imaged using Fiji v1.53c, (https://fiji.sc/) with two
additional plugins, 3D ImageJ Suite (Ollion et al., 2013) and MorphoLib (Legland et al.
2016)(available online).

« Ollion, J. et al., Bioinformatics, 29, 1840-1841 (2013)
« Legland, D. et al., Bioinformatics, 32, 2532-2534 (2016)

A code was written to automate the image analysis, Ganglia macro.ijm (code). This script
applies a given threshold and then applies filters to smooth and remove small particles
from the image and generates a mask (or binary image) of the immunoreactivity
selected. This mask contains 3 dimensional (3D) objects, representing any positive
staining generated above the given threshold. Objects with greater than 20 um distance
separating them are defined as regions of interest (roi) representing individual ganglia.
Within each image, a unique intensity value is assigned to each ganglia roi, which can be
used as an identifier.

For each image, the script is run twice, each time with a specific threshold is set by the
experimenter which represents the immunoreactivity of the antibodies, to ensure that
both low intensity and high intensity staining is captured accurately.

Ganglia roi from the two thresholds were manually checked against each other and
against the original image to remove duplications and artefacts, and to also be assigned
as either MP or SMP as defined by their position in the z stack. Two final masks are
generated, a set of ganglia roi which most accurately represents all myenteric plexus
(MP) ganglia and another for all the submucosa plexus (SMP) ganglia from the original
image.

Ganglia roi are then used to collect volume measurements (3D) from the z stack images,
or to collect ganglia profile area measurements (2D) after projecting the z-stacks into a
single image. The total area of the image was also measured for calculating ganglia
density. Measurement data was then exported from ImagedJ into excel and calculations
were completed to determine ganglia areas and number of neurons per ganglia
throughout all three regions of the stomach.

See below for a more detailed description of these steps:
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8 Running the macro file Ganglia macro.ijm

e Open Ganglia macro.ijm (code) in ImagedJ (with above plugins installed)

e Click RUN and use the default settings shown below, click OK

[v Set Threshold (for each image)
[~ Select Regions
v Analysis

Specify the label for each channel (can leave blank if not needead for analysis)

Channel 1 |Hu Channel 2 Channel 3 Channel 4 |
Which channel is Hu?

¥ Channel1 I~ Channel2 [~ Channel3 [~ Channel 4
Which channels should be analysed for their intensity in Hu cells?

W Channel1 I” Channel2 [~ Channel3 [ Channel 4

What is the minimum distance between separate ganglia?

(microns) |20

Options when analysing images:

Region

& Analyse enfire image " Analyse region of interest

Thresholding

" Pre-get threshold for all images & Individually

If using a pre-set threshold, specify threshold values (can leave blank if channel not in use):

Channel 1 |25 Channel 2 |0 Channel 3 |0 Channel 4 |D

Do you want to analyse ganglia and cells?

" Ganglia and cells & Just ganglia

o follow the prompts

- select the FOLDER-A containing the single sam-xxx_ses-hu594_bg10.tif file

- choose a threshold suitable for brightly stained ganglia (~10, this will be threshold
A)
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- make sure live roi is ON
The log window will say “done”" when macro is complete.
* Open FOLDER-A to view the macro generated results folders.
e Open the Results folder and the Channel 1 Thresholds.txt file to view the chosen
threshold.
- rename file sam-xxx_ses-hu594_Channel 1 Thresholds A.txt where A is the
numerical value of the threshold
e Open Mask folder and rename file sam-xxx_ses-hu594_bg10-thrA.tif where A is
the numerical value of the threshold
Repeat macro
o Place file sam-xxx_ses-hu594_bg10.tif into a new folder FOLDER-B
o Repeat the entire macro process on FOLDER-B using a second threshold to detect
weaker ganglia (~6, this will be threshold B)

- rename files sam-xxx_ses-hu594_Channel 1 Thresholds B.txt and sam-xxx_ses-
hu594_bg10-thrB.tif

9 Analyzing macro results

The mask files sam-xxx_ses-hu594_bg10-thrA.tif and sam-xxx_ses-hu594_bg10-
thrB.tif contain 3D objects, or regions of interest (roi), representing any ganglia or
positive staining generated with the given threshold. The colors visualized are generated
at random, however the color pixel value (if you measure the maximum grey value) will
be a unique value for each object within that image and can be used as an identifier.

The aim is to use the two masks to generate a set of 3D objects which most accurately
represents all MP ganglia and all SMP ganglia from the original image, and then collect
measurement data from those 3D objects.

Open template excel file and rename sam-xxx_ses-hu594.xIsx

Open Imaged
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+ Imaged > Analyze > Set Measurements
- set measurements as shown

v Area [+ Mean gray value
[ Standard deviation [ Modal grayvalue
v Min & max grayvalue [ Centroid

[ Center of mass [ Perimeter

| Bounding rectangle [ Fitellipse

[~ Shape descriptors [ Feret's diameter
[ Integrated density [ Median

[ Skewness [ Kurtosis

[ Areafraction [ Stack position

[ Limittothreshold [ Display label
[ InvertY coordinates [ Scientific notation
| Addto overlay | MaM empty cells

Redirect to: |Nnne -

Decimal places (0-9): |3

Ok | Canu::el| Help|

* ImagedJ > Plugins > 3D > 3D Manager to open the 3D RoiManager
- Click the tools icon and set measurements as shown:
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e Open sam-xxx_ses-hu594_bg10.tif in ImageJ
- ImagedJ > Image > Stacks > Z Project
- (settings: All slices, Max Intensity)
- Save as tif > sam-xxx_ses-hu594_bg10-max.tif
- These are 3D and 2D images of the background corrected Hu staining

e Select sam-xxx_ses-hu594_bg10-max.tif

- adjust brightness and contrast to optimize visualization of the staining

- use the polygon tool to outline the entire region of the image which contains tissue
which will be quantified (avoid regions with no tissue or with large artefacts) and press t
to create a 2D region of interest (roi).

- Save as roi as > sam-xxx_ses-hu594_area.roi

e Open sam-xxx_ses-hu594_bg10_thrA.tif in ImageJ

Imaged > 3D Manager > Add Image to extract the ROIs from the mask
Imaged > 3D Manager > Select All > Measure 3D

copy all results and paste into “raw threshold A" worksheet in excel
Also enter the sample name (cell A1) and the threshold value (cell J1)

+ ImagedJ > 3D Manager > Select all, then Label
- Imaged > Image > Stacks > Z Project
- (settings: All slices, Max Intensity)
- Save as tif > sam-xxx_ses-hu594_bg10-thrA-label.tif
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- this creates a 2D labelled map of all objects from the threshold A mask.
- The "val-" number listed on the labels corresponds to the unique pixel value of
each object.

e Open sam-xxx_ses-hu594_bg10_thrA.tif in ImageJ and repeat the above 2 steps
for the threshold B mask.

- Save as tif > sam-xxx_ses-hu594_bg10-thrB-label.tif

- paste measurements into the "raw threshold B" worksheet in excel

e Close all files

e Open sam-xxx_ses-hu594_bg10-max.tif adjust brightness and contrast, and
manually compare it to the 2D labelled maps from both thresholds to identify which mask
objects most accurately represent the staining and which ones are incorrectly
thresholded or represent staining artefacts

e Open sam-xxx_ses-hu594_bg10.tif adjust brightness and contrast, and manually
compare the position of each of the selected correct mask objects to the same location
in the z stacked image. The z-stack position in the tissue, relative to other nearby
ganglia, is used to determine whether each correct ganglia object should be assigned to
the MP or SMP layer

o Record the unique pixel values of the chosen 3D roi objects in the "Roi subsets"
worksheet in excel as follows
(note, the unique pixel value is listed as the "val-" number on the labelled image, or you
can measure the maximum grey value)

- cell A6 - roi pixel value for each object from sam-xxx_ses-hu594_bg10-thrA.tif
which is not included in the final MP or SMP subset

- cell D6 - roi pixel value for each object from sam-xxx_ses-hu594_bg10-thrA.tif
which is included in the final SMP subset
(note: objects from thrA which are NOT in the above two columns comprise the thrA MP
subset)

- cell G6 - roi pixel value for each object from sam-xxx_ses-hu594_bg10-thrB.tif
which is included in the final MP subset

- cell J6 - roi pixel value for each object from sam-xxx_ses-hu594_bg10-thrB.tif
which is included in the final SMP subset
(note: objects from thrB which are NOT in the above two columns are not included in the
final subsets)

e Open sam-xxx_ses-hu594_bg10_thrA.tif in ImageJ
- Imaged > 3D Manager > Add Image to extract the ROIs from the mask
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- use the object values listed in the "Roi subsets" worksheet to manually select all
rois with values that DONT correspond to the thrA SMP subset and select ERASE to
remove them from the mask

- temporarily save this thrA-SMP-subset image

- Imaged > 3D Manager > Select All > Measure 3D

- copy all results and paste into “"subsets measurements” worksheet in excel (cell
A5)

- close all images and delete remaining rois from the 3D RoiManager

e Reopen sam-xxx_ses-hu594_bg10_thrA.tif in ImageJ

- Imaged > 3D Manager > Add Image to extract the ROIs from the mask

- use the object values listed in the "Roi subsets" worksheet to manually select all
rois with values that DONT correspond to the thrA MP subset and select ERASE to
remove them from the mask

- temporarily save this thrA-MP-subset image

- Imaged > 3D Manager > Select All > Measure 3D

- copy all results and paste into “"subsets measurements” worksheet in excel (cell
H5)

- close all images and delete remaining rois from the 3D RoiManager

e Open sam-xxx_ses-hu594_bg10_thrB.tif in ImageJ

- Imaged > 3D Manager > Add Image to extract the ROIs from the mask

- use the object values listed in the "Roi subsets" worksheet to manually select all
rois with values that DONT correspond to the thrB SMP subset and select ERASE to
remove them from the mask

- temporarily save this thrB-SMP-subset image

- Imaged > 3D Manager > Select All > Measure 3D

- copy all results and paste into “subsets measurements” worksheet in excel (cell P5)

- close all images and delete remaining rois from the 3D RoiManager

e Reopen sam-xxx_ses-hu594_hbg10_thrB.tif in ImageJ

- ImagedJ > 3D Manager > Add Image to extract the ROIs from the mask

- use the object values listed in the "Roi subsets" worksheet to manually select all
rois with values that DONT correspond to the thrB MP subset and select ERASE to
remove them from the mask

- temporarily save this thrB-MP-subset image

- Imaged > 3D Manager > Select All > Measure 3D

- copy all results and paste into “"subsets measurements” worksheet in excel (cell
W5)

o Create a single mask containing only the correct roi objects representing all MP
ganglia
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Open the thrA-MP-subset image in ImageJ
ImagedJ > 3D Manager > Add Image
Open the thrB-MP-subset image in ImagedJ
ImagedJ > 3D Manager > Add Image
Imaged > Process > Image Calculator to ADD the two images

- (settings thrA-MPsubset ADD thrB-MP-subset, create new window yes, 32-bit float
no)

- Save as tif > sam-xxx_ses-hu594_bg10-MPsubset.tif

- Imaged > 3D Manager > Select All > Measure 3D

- copy all results and paste into “3D area measurements” worksheet in excel (cell
A14)
note: you have to "Add Image" from the thrA and thrB subsets separately as described,
because the unique object pixel values may be doubled up between the two thresholded
images, which would result in them not adding correctly from the final MPsubset image

o Create a 2D maximum projection image of the mask for 2D measurements
- Imaged > Image > Stacks > Z Project
- (settings: All slices, Max Intensity)
- Save as tif > sam-xxx_ses-hu594_bg10-MPsubset-max.tif

e Create 2D rois.

- Select sam-xxx_ses-hu594_bg10-MPsubset-max.tif, ImageJ > Image >
Duplicate

- Select duplicated image, Imaged > Image > Adjust > Threshold

- (settings: 1- 65535, default, red, dark background yes, other boxes unchecked)

- Imaged > Analyze > Analyze particles

- (settings: size 0-infinity, circularity 0.00-1.00, show nothing, add to manager yes,
other boxes unchecked)

- Select sam-xxx_ses-hu594_bg10-MPsubset-max.tif, ImageJ > Analyze >
Measure

- copy all results and paste into “2D area measurements” worksheet in excel (cell
A14)

- fill down formula in column F for all measurements, to correct for any holes inside
the 2D roi outline which do not contain neurons/ganglia

- in ImagedJ, select all 2D rois in the ROl Manager and click Properties, change color
to cyan

- Save as roiset as > sam-xxx_ses-hu594_MP.zip

» close all images and delete remaining rois from the 3D RoiManager and 2D ROI
Manager
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+ Create a single mask containing only the correct roi objects representing all SMP
ganglia
Open the thrA-SMP-subset image in ImageJ
ImagedJ > 3D Manager > Add Image
Open the thrB-SMP-subset image in ImageJ
Imaged > 3D Manager > Add Image
Imaged > Process > Image Calculator to ADD the two images

- (settings thrA-SMPsubset ADD thrB-SMP-subset, create new window yes, 32-bit
float no)

- Save as tif > sam-xxx_ses-hu594_bg10-SMPsubset.tif

- Imaged > 3D Manager > Select All > Measure 3D

- copy all results and paste into “3D area measurements” worksheet in excel (cell
H14)
note: you have to Add Image from the thrA and thrB subsets separately as described,
because the unique object pixel values may be doubled up between the two thresholded
images, which would result in them not adding correctly from the final SMPsubset image

e Create a 2D maximum projection image of the mask for 2D measurements
- Imaged > Image > Stacks > Z Project
- (settings: All slices, Max Intensity)
- Save as tif > sam-xxx_ses-hu594_bg10-SMPsubset-max.tif

e Create 2D rois.

- Select sam-xxx_ses-hu594_bg10-SMPsubset-max.tif, ImageJ > Image >
Duplicate

- Select duplicated image, Imaged > Image > Adjust > Threshold

- (settings: 1- 65535, default, red, dark background yes, other boxes unchecked)

- Imaged > Analyze > Analyze particles

- (settings: size 0-infinity, circularity 0.00-1.00, show nothing, add to manager yes,
other boxes unchecked)

- Select sam-xxx_ses-hu594_bg10-SMPsubset-max.tif, ImageJ > Analyze >
Measure

- copy all results and paste into “2D area measurements” worksheet in excel (cell
H14)

- fill down formula in column M for all measurements, to correct for any holes inside
the 2D roi outline which do not contain neurons/ganglia

- in Imaged, select all 2D rois

- Save as roiset as > sam-xxx_ses-hu594_SMP.zip

e close all images and delete remaining rois from the 3D RoiManager and 2D ROI
Manager
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e Open sam-xxx_ses-hu594_bg10_MPsubset-max.tif in ImageJ

- Open sam-xxx_ses-hu594_area.roi, sam-xxx_ses-hu594_MP.zip and sam-
xxx_ses-hu594_SMP.zip

- Select all roi and save roiset as > sam-xxx_ses-hu594_ALL.zip

« close all images and delete remaining rois from the 3D RoiManager and 2D ROI
Manager

e Check final worksheet (Sheet1) to see if the number of rois is consistent between
worksheets and that no manual errors have been made. Green cells in column D indicate
that the number of objects/rois matches.

- 2D measurements (cell D18, D19) are likely to not match, since ganglia may be
discontiguous (but with less than 20um separation) and these will initially be detected as
separate 2D objects. Manually identify discontiguous ganglia (with matching value/IDs)
and combine 2D measurements into a single corrected entry.

- When z projecting 3D objects, overlapping 3D rois may also be incorrectly detected as
a single 2D object. Manually identify overlapping 3D rois and individually project them to
obtain correct individual 2D rois.

- Ensure the corrected 2D measurements (cell D22, D23) have been manually corrected
and are green before exporting measurement data.
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